LDAP OID Reference Guide
Luke Hebert
- 4 minutes read - 804 wordsObject identifiers are used throughout LDAP, but they’re particularly common in schema elements, controls, and extended operations. This reference table covers some of the most common OIDs used in LDAP along with a brief explanation of their purpose and, where applicable, a link to the appropriate specification.
OID Reference Table
| OID | Purpose | Source |
|---|---|---|
| 0.9.2342.19200300.100.1.1 | uid Attribute Type | RFC 4519 |
| 0.9.2342.19200300.100.1.2 | textEncodedORAddress Attribute Type | RFC 1274 |
| 0.9.2342.19200300.100.1.3 | mail Attribute Type | RFC 4524 |
| 0.9.2342.19200300.100.1.4 | info Attribute Type | RFC 4524 |
| 0.9.2342.19200300.100.1.5 | drink Attribute Type | RFC 4524 |
| 0.9.2342.19200300.100.1.6 | roomNumber Attribute Type | RFC 4524 |
| 0.9.2342.19200300.100.1.7 | photo Attribute Type | RFC 2798 |
| 0.9.2342.19200300.100.1.8 | userClass Attribute Type | RFC 4524 |
| 0.9.2342.19200300.100.1.9 | host Attribute Type | RFC 4524 |
| 0.9.2342.19200300.100.1.10 | manager Attribute Type | RFC 4524 |
| 0.9.2342.19200300.100.1.11 | documentIdentifier Attribute Type | RFC 4524 |
| 0.9.2342.19200300.100.1.12 | documentTitle Attribute Type | RFC 4524 |
| 0.9.2342.19200300.100.1.13 | documentVersion Attribute Type | RFC 4524 |
| 0.9.2342.19200300.100.1.14 | documentAuthor Attribute Type | RFC 4524 |
| 0.9.2342.19200300.100.1.15 | documentLocation Attribute Type | RFC 4524 |
| 0.9.2342.19200300.100.1.20 | homePhone Attribute Type | RFC 4524 |
| 0.9.2342.19200300.100.1.21 | secretary Attribute Type | RFC 4524 |
| 0.9.2342.19200300.100.1.22 | otherMailbox Attribute Type | RFC 1274 |
| 0.9.2342.19200300.100.1.23 | lastModifiedTime Attribute Type | RFC 1274 |
| 0.9.2342.19200300.100.1.24 | lastModifiedBy Attribute Type | RFC 1274 |
| 0.9.2342.19200300.100.1.25 | dc Attribute Type | RFC 4519 |
| 0.9.2342.19200300.100.1.26 | aRecord Attribute Type | RFC 1274 |
| 0.9.2342.19200300.100.1.27 | mDRecord Attribute Type | RFC 1274 |
| 0.9.2342.19200300.100.1.28 | mxRecord Attribute Type | RFC 1274 |
| 0.9.2342.19200300.100.1.29 | nSRecord Attribute Type | RFC 1274 |
| 0.9.2342.19200300.100.1.30 | sOARecord Attribute Type | RFC 1274 |
| 0.9.2342.19200300.100.1.31 | cNAMERecord Attribute Type | RFC 1274 |
| 0.9.2342.19200300.100.1.37 | associatedDomain Attribute Type | RFC 4524 |
| 0.9.2342.19200300.100.1.38 | associatedName Attribute Type | RFC 4524 |
| 0.9.2342.19200300.100.1.39 | homePostalAddress Attribute Type | RFC 4524 |
| 0.9.2342.19200300.100.1.40 | personalTitle Attribute Type | RFC 4524 |
| 0.9.2342.19200300.100.1.41 | mobile Attribute Type | RFC 4524 |
| 0.9.2342.19200300.100.1.42 | pager Attribute Type | RFC 4524 |
| 0.9.2342.19200300.100.1.43 | co Attribute Type | RFC 4524 |
| 0.9.2342.19200300.100.1.44 | uniqueIdentifier Attribute Type | RFC 4524 |
| 0.9.2342.19200300.100.1.45 | organizationalStatus Attribute Type | RFC 4524 |
| 0.9.2342.19200300.100.1.46 | janetMailbox Attribute Type | RFC 1274 |
| 0.9.2342.19200300.100.1.47 | mailPreferenceOption Attribute Type | RFC 1274 |
| 0.9.2342.19200300.100.1.48 | buildingName Attribute Type | RFC 4524 |
| 0.9.2342.19200300.100.1.49 | dSAQuality Attribute Type | RFC 1274 |
| 0.9.2342.19200300.100.1.50 | singleLevelQuality Attribute Type | RFC 1274 |
| 0.9.2342.19200300.100.1.51 | subtreeMinimumQuality Attribute Type | RFC 1274 |
| 0.9.2342.19200300.100.1.52 | subtreeMaximumQuality Attribute Type | RFC 1274 |
| 0.9.2342.19200300.100.1.53 | personalSignature Attribute Type | RFC 1274 |
| 0.9.2342.19200300.100.1.54 | dITRedirect Attribute Type | RFC 1274 |
| 0.9.2342.19200300.100.1.55 | audio Attribute Type | RFC 2798 |
| 0.9.2342.19200300.100.1.56 | documentPublisher Attribute Type | RFC 4524 |
| 0.9.2342.19200300.100.1.60 | jpegPhoto Attribute Type | RFC 2798 |
| 0.9.2342.19200300.100.4.3 | pilotObject Object Class | RFC 1274 |
| 0.9.2342.19200300.100.4.4 | pilotPerson Object Class | RFC 1274 |
| 0.9.2342.19200300.100.4.5 | account Object Class | RFC 4524 |
| 0.9.2342.19200300.100.4.6 | document Object Class | RFC 4524 |
| 0.9.2342.19200300.100.4.7 | room Object Class | RFC 4524 |
| 0.9.2342.19200300.100.4.9 | documentSeries Object Class | RFC 4524 |
| 0.9.2342.19200300.100.4.13 | domain Object Class | RFC 4524 |
| 0.9.2342.19200300.100.4.14 | rFC822localPart Object Class | RFC 4524 |
| 0.9.2342.19200300.100.4.15 | dNSDomain Object Class | RFC 1274 |
| 0.9.2342.19200300.100.4.17 | domainRelatedObject Object Class | RFC 4524 |
| 0.9.2342.19200300.100.4.18 | friendlyCountry Object Class | RFC 4524 |
| 0.9.2342.19200300.100.4.19 | simpleSecurityObject Object Class | RFC 4524 |
| 0.9.2342.19200300.100.4.20 | pilotOrganization Object Class | RFC 1274 |
| 0.9.2342.19200300.100.4.21 | pilotDSA Object Class | RFC 1274 |
| 0.9.2342.19200300.100.4.22 | qualityLabelledData Object Class | RFC 1274 |
| 1.2.826.0.1.3344810.2.3 | Matched Values Request Control | RFC 3876 |
| 1.2.840.113549.1.9.1 | emailAddress Attribute Type | RFC 2985 |
| 1.2.840.113549.1.9.2 | unstructuredName Attribute Type | RFC 2985 |
| 1.2.840.113549.1.9.3 | contentType Attribute Type | RFC 2985 |
| 1.2.840.113549.1.9.4 | messageDigest Attribute Type | RFC 2985 |
| 1.2.840.113549.1.9.5 | signingTime Attribute Type | RFC 2985 |
| 1.2.840.113549.1.9.6 | counterSignature Attribute Type | RFC 2985 |
| 1.2.840.113549.1.9.7 | challengePassword Attribute Type | RFC 2985 |
| 1.2.840.113549.1.9.8 | unstructuredAddress Attribute Type | RFC 2985 |
| 1.2.840.113549.1.9.24.1 | pkcsEntity Object Class | RFC 2985 |
| 1.2.840.113549.1.9.24.2 | naturalPerson Object Class | RFC 2985 |
| 1.2.840.113549.1.9.25.1 | pKCS15Token Attribute Type | RFC 2985 |
| 1.2.840.113549.1.9.25.2 | encryptedPrivateKeyInfo Attribute Type | RFC 2985 |
| 1.2.840.113549.1.9.25.5 | pKCS7PDU Attribute Type | RFC 2985 |
| 1.2.840.113549.6.0.0 | Signed Operation Request Control | RFC 2649 |
| 1.2.840.113549.6.0.1 | Demand Signed Result Request Control | RFC 2649 |
| 1.2.840.113549.6.0.2 | Signed Result Response Control | RFC 2649 |
| 1.2.840.113549.6.1.0 | signedAuditTrail Object Class | RFC 2649 |
| 1.2.840.113549.6.1.2 | zombieObject Object Class | RFC 2649 |
| 1.2.840.113549.6.2.0 | Changes Attribute Type | RFC 2649 |
| 1.2.840.113549.6.2.1 | OriginalObject Attribute Type | RFC 2649 |
| 1.2.840.113549.6.2.2 | signedDirectoryOperationSupport Attribute Type | RFC 2649 |
| 1.2.840.113556.1.4.319 | Simple Paged Results Control | RFC 2696 |
| 1.2.840.113556.1.4.473 | Server-Side Sort Request Control | RFC 2891 |
| 1.2.840.113556.1.4.474 | Server-Side Sort Response Control | RFC 2891 |
| 1.2.840.113556.1.4.478 | calCalURI Attribute Type | RFC 2739 |
| 1.2.840.113556.1.4.479 | calFBURL Attribute Type | RFC 2739 |
| 1.2.840.113556.1.4.480 | calCAPURI Attribute Type | RFC 2739 |
| 1.2.840.113556.1.4.481 | calCalAdrURI Attribute Type | RFC 2739 |
| 1.2.840.113556.1.4.482 | calOtherCalURIs Attribute Type | RFC 2739 |
| 1.2.840.113556.1.4.483 | calOtherFBURLs Attribute Type | RFC 2739 |
| 1.2.840.113556.1.4.484 | calOtherCAPURIs Attribute Type | RFC 2739 |
| 1.2.840.113556.1.4.485 | calOtherCalAdrURIs Attribute Type | RFC 2739 |
| 1.2.840.113556.1.4.841 | DirSync Request Control | Microsoft Active Directory |
| 1.2.840.113556.1.4.1413 | Permissive Modify Request Control | Microsoft Active Directory |
| 1.2.840.113556.1.4.1504 | Attribute Scoped Query Request Control | draft-kashi-attr-scoped-query |
| 1.2.840.113556.1.5.87 | calEntry Object Class | RFC 2739 |
| 1.3.6.1.1.1.1.0 | uidNumber Attribute Type | RFC 2307 |
| 1.3.6.1.1.1.1.1 | gidNumber Attribute Type | RFC 2307 |
| 1.3.6.1.1.1.1.2 | gecos Attribute Type | RFC 2307 |
| 1.3.6.1.1.1.1.3 | homeDirectory Attribute Type | RFC 2307 |
| 1.3.6.1.1.1.1.4 | loginShell Attribute Type | RFC 2307 |
| 1.3.6.1.1.1.1.5 | shadowLastChange Attribute Type | RFC 2307 |
| 1.3.6.1.1.1.1.6 | shadowMin Attribute Type | RFC 2307 |
| 1.3.6.1.1.1.1.7 | shadowMax Attribute Type | RFC 2307 |
| 1.3.6.1.1.1.1.8 | shadowWarning Attribute Type | RFC 2307 |
| 1.3.6.1.1.1.1.9 | shadowInactive Attribute Type | RFC 2307 |
| 1.3.6.1.1.1.1.10 | shadowExpire Attribute Type | RFC 2307 |
| 1.3.6.1.1.1.1.11 | shadowFlag Attribute Type | RFC 2307 |
| 1.3.6.1.1.1.1.12 | memberUid Attribute Type | RFC 2307 |
| 1.3.6.1.1.1.1.13 | memberNisNetgroup Attribute Type | RFC 2307 |
| 1.3.6.1.1.1.1.14 | nisNetgroupTriple Attribute Type | RFC 2307 |
| 1.3.6.1.1.1.1.15 | ipServicePort Attribute Type | RFC 2307 |
| 1.3.6.1.1.1.1.16 | ipServiceProtocol Attribute Type | RFC 2307 |
| 1.3.6.1.1.1.1.17 | ipProtocolNumber Attribute Type | RFC 2307 |
| 1.3.6.1.1.1.1.18 | oncRpcNumber Attribute Type | RFC 2307 |
| 1.3.6.1.1.1.1.19 | ipHostNumber Attribute Type | RFC 2307 |
| 1.3.6.1.1.1.1.20 | ipNetworkNumber Attribute Type | RFC 2307 |
| 1.3.6.1.1.1.1.21 | ipNetmaskNumber Attribute Type | RFC 2307 |
| 1.3.6.1.1.1.1.22 | macAddress Attribute Type | RFC 2307 |
| 1.3. |